Еще вопрос про обновление системы

Added by jone j 6 days ago

1. Запускаю с дефолтными настройками, от удаления всей простыни пакетов (первый скриншот) отказываюсь, прерываю, выход.
2. Тут же запускаю повторно, но в итоге получаю совсем иной результат (скриншот 2).
Это так и задумано? А где можно прочитать про такую фичу? Подружусь ли я когда-нибудь вообще с Gentoo-Calculate? :) Одни вопросы))

00.png - первый запуск (длина списка выделена красным) (132.2 KB)

01.png - повторный запуск (93.1 KB)


Replies (3)

RE: Еще вопрос про обновление системы - Added by jone j 6 days ago

Хвост списка (еще скриншот, так как почему-то нет возможности выделить весть текст в окне), беру из него например x11-proto/dri2proto и:

emerge -cav x11-proto/dri2proto

Calculating dependencies... done!
  x11-proto/dri2proto-2.8-r1 pulled in by:
    media-libs/mesa-17.0.6 requires >=x11-proto/dri2proto-2.8-r1:=[abi_x86_32(-),abi_x86_64(-)], >=x11-proto/dri2proto-2.8-r1:0/0=[abi_x86_32(-),abi_x86_64(-)]
    x11-base/xorg-server-1.19.3 requires >=x11-proto/dri2proto-2.8
    x11-drivers/xf86-video-amdgpu-1.4.0 requires x11-proto/dri2proto
    x11-drivers/xf86-video-ati-7.10.0 requires x11-proto/dri2proto
    x11-drivers/xf86-video-intel-2.99.917_p20170313 requires x11-proto/dri2proto, >=x11-proto/dri2proto-2.6
    x11-drivers/xf86-video-nouveau-1.0.15 requires x11-proto/dri2proto
    x11-drivers/xf86-video-openchrome-0.6.0 requires x11-proto/dri2proto
    x11-libs/libvdpau-1.1.1 requires >=x11-proto/dri2proto-2.2

>>> No packages selected for removal by depclean
Packages installed:   1068
Packages in world:    210
Packages in system:   44
Required packages:    1068
Number removed:       0

Упс!
Тогда может быть emerge -av --depclean?

emerge -av --depclean

>>> No packages selected for removal by depclean
Packages installed:   1068
Packages in world:    210
Packages in system:   44
Required packages:    1068
Number removed:       0

Да-да, я понимаю, что у всех все работает)) Но не понимаю, почему не работает конкретно в моей системе? Сразу прошу извинить, разбираться в Gentoo абсолютно неинтересно, терплю Portage и все надстройки как неизбежное зло.

02-5.png - хвост списка (194.6 KB)

RE: Еще вопрос про обновление системы - Added by jone j 5 days ago

Резюме: кривая надстройка на python над изначально кривым Portage, который тоже на python. И никакого уважения к тем полутора разработчикам, что так натужно быдлокодят. Я не стану в этом разбираться, и подумаю, как в ближайшие сроки заменить ЭТО на что-то адекватное.

RE: Еще вопрос про обновление системы - Added by Alexander Tratsevskiy 4 days ago

Да-да, я понимаю, что у всех все работает)) Но не понимаю, почему не работает конкретно в моей системе? Сразу прошу извинить, разбираться в Gentoo абсолютно неинтересно, терплю Portage и все надстройки как неизбежное зло.

В логе портежей видно с какими опциями вызывается менеджер пакетов.

Резюме: кривая надстройка на python над изначально кривым Portage, который тоже на python. И никакого уважения к тем полутора разработчикам, что так натужно быдлокодят. Я не стану в этом разбираться, и подумаю, как в ближайшие сроки заменить ЭТО на что-то адекватное.

Запомните, вам тут никто ничем не обязан. Так что давай, до свидания.

(1-3/3)

Thank you!