ошибка в eselect python

Added by Alex Zhihorev 6 months ago

Добрый день.
Поставил CSS.
делаю eselect python list

eselect python list
Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.4

пытыюсь активировать питон-2.7

eselect python set 1
Couldn't find a man page for python2.7; skipping.

Получаю такую ошибку.

Мои действия:

python-updater >> ошибок нет
revdep-rebuild >> ошибок нет

eselect python update --python2 >> eselect python update --python2
Ignoring Python 2 preference update as non-meaningful

eselect python update --python3 >> eselect python update --python3
Switching to python3.4
Couldn't find a man page for python2.7; skipping.

Replies (6)

RE: ошибка в eselect python - Added by Mikhail Hiretsky 6 months ago

Какой build у поставленной системы?

RE: ошибка в eselect python - Added by Alex Zhihorev 6 months ago

[I] app-eselect/eselect-python
Доступные версии: 20140125-r2 20160516{tbz2} **99999999
Установленные версии: 20160516{tbz2}(10:58:18 11.01.2017)
Домашняя страница: https://www.gentoo.org/proj/en/Python/
Описание: Eselect module for management of multiple Python versions

RE: ошибка в eselect python - Added by Mikhail Hiretsky 6 months ago

grep os_linux_build /var/lib/calculate/calculate.env

RE: ошибка в eselect python - Added by Alex Zhihorev 6 months ago

grep os_linux_build /var/lib/calculate/calculate.env
os_linux_build = 20170310

RE: ошибка в eselect python - Added by Mikhail Hiretsky 6 months ago

Попробуйте последний build. Указанная сборка к сожалению не сохранилась, а в последующих стейджах эту проблему не обнаружил.

RE: ошибка в eselect python - Added by Alex Zhihorev 5 months ago

последний ebuild проблемы не решает.
откатился на версию:

[I] dev-lang/python-exec
     Установленные версии:  2.4.4

в такой версии проблема не повторяется.

(1-6/6)

Thank you!