Конфликт, однако

Added by Алексей Добрынин almost 2 years ago

Не могу обновиться, а заниматься маскировками не хоцца.
Разработчики, гляньте, пжлста, может нужно что-то поправить ?

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

app-text/poppler:0

  (app-text/poppler-0.42.0:0/59::gentoo, ebuild scheduled for merge) conflicts with
    app-text/poppler:0/51 required by (app-office/libreoffice-bin-5.0.5.2-r1:0/0::gentoo, ebuild scheduled for merge)
                    ^^^^^
    >=app-text/poppler-0.32:0/51=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.5.0:0/0::gentoo, binary scheduled for merge)
                           ^^^^^^                                    


Replies (5)

RE: Конфликт, однако - Added by Alexander Tratsevskiy almost 2 years ago

Размаскируйте app-office/libreoffice-bin-5.1.2.2-r1, предыдущая версия требует app-text/poppler-0.32.0, что вызывает конфликт с установленным и стабильным 0.42.0.

RE: Конфликт, однако - Added by Алексей Добрынин almost 2 years ago

Спасибо, я видел такой вариант решения, не хотелось заниматься маскировкой/размаскировкой.
Да и ждал стабилизации офиса.

RE: Конфликт, однако - Added by Alexander Tratsevskiy almost 2 years ago

В данном случае мы собираем бинарный libreoffice и протестировать совместимость с libreoffice-bin не представляется возможным. ebuild poppler-0.42.0 стабилен в портежах, здесь скорей особенность ebuild-а бинарного пакета, который собран жёстко с poppler-0.32.0.

RE: Конфликт, однако - Added by Матвей Бакиров almost 2 years ago

Продолжаем тему poppler. Теперь офис свежий, требует 42ую версию, а cups требует 43! Кто не прав?

app-text/poppler:0

  (app-text/poppler-0.43.0:0/60::gentoo, binary scheduled for merge) pulled in by
    >=app-text/poppler-0.32:0/60=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.5.0:0/0::gentoo, binary scheduled for merge)
                           ^^^^^^                                                                                                                                                           

  (app-text/poppler-0.42.0:0/59::gentoo, installed) pulled in by
    app-text/poppler:0/59 required by (app-office/libreoffice-bin-5.1.2.2-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                               
    >=app-text/poppler-0.16:0/59=[cxx] required by (app-office/libreoffice-bin-5.1.2.2-r1:0/0::gentoo, installed)
                           ^^^^^^  

RE: Конфликт, однако - Added by Денис Терехов almost 2 years ago

Такая же фигня.
Libreoffice-bin, как я понял, собирают жестко с poppler.

(1-5/5)

Thank you!