[РЕШЕНО] kicad перестал работать

Added by Александр Красов 5 months ago

# kicad
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
Аварийный останов

Не могу понять, о какой библиотеке идет речь.
eix wx
[I] app-eselect/eselect-wxwidgets
     Доступные версии:      20140423{tbz2}
     Установленные версии:  20140423{tbz2}(16:10:18 05.07.2018)
     Домашняя страница:     https://www.gentoo.org
     Описание:              Eselect module and wrappers for wxWidgets

[I] dev-python/wxpython
     Доступные версии:      
     (2.8)  [M]2.8.12.1-r2
     (3.0)  3.0.2.0{tbz2}
       {cairo doc examples libnotify opengl PYTHON_TARGETS="python2_7"}
     Установленные версии:  3.0.2.0(3.0){tbz2}(10:25:03 30.07.2018)(cairo libnotify opengl -examples PYTHON_TARGETS="python2_7")
     Домашняя страница:     http://www.wxpython.org/
     Описание:              A blending of the wxWindows C++ class library with Python

[I] x11-libs/wxGTK
     Доступные версии:      
     (2.8)  [M]2.8.12.1-r2
     (3.0)  3.0.3{tbz2} ~3.0.4
     (3.0-gtk3) 3.0.3-r300{tbz2} ~3.0.4-r300
       {+X aqua debug doc gnome gstreamer libnotify odbc opengl pch sdl tiff webkit ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Установленные версии:  3.0.3(3.0){tbz2}(23:48:33 09.01.2018)(X gstreamer libnotify opengl sdl tiff -aqua -debug -doc ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32") 3.0.3-r300(3.0-gtk3){tbz2}(11:47:39 27.07.2018)(X gstreamer libnotify opengl sdl tiff webkit -aqua -debug -doc ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Домашняя страница:     https://wxwidgets.org/
     Описание:              GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit

Пересборка
FEATURES="-getbinpkg" emerge -av wxpython wxGTK

Результатов не дала.

Replies (1)

RE: [РЕШЕНО] kicad перестал работать - Added by Александр Красов 4 months ago

# eix wxGTK
[I] x11-libs/wxGTK
     Доступные версии:      
     (2.8)  [M]2.8.12.1-r2
     (3.0)  3.0.3{tbz2} ~3.0.4
     (3.0-gtk3) 3.0.3-r300{tbz2} ~3.0.4-r300
       {+X aqua debug doc gnome gstreamer libnotify odbc opengl pch sdl tiff webkit ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Установленные версии:  3.0.3(3.0){tbz2}(23:48:33 09.01.2018)(X gstreamer libnotify opengl sdl tiff -aqua -debug -doc ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32") 3.0.3-r300(3.0-gtk3){tbz2}(16:36:14 31.07.2018)(X gstreamer libnotify opengl sdl tiff webkit -aqua -debug -doc ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Домашняя страница:     https://wxwidgets.org/
     Описание:              GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit

После сноса обеих библиотек
# emerge -C  wxGTK
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

 x11-libs/wxGTK
    selected: 3.0.3 3.0.3-r300 
   protected: none 
     omitted: none

Проблема осталась и я не понял, что это такое.
# kicad
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
Аварийный останов

Далее
# emerge @preserved-rebuild

Local copy of remote index is up-to-date and will be used.

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
>>> Running pre-merge checks for sci-electronics/kicad-4.0.7
 * kicad-4.0.7.tbz2 MD5 SHA1 size ;-) ...                                [ ok ]
>>> Emerging binary (1 of 3) x11-libs/wxGTK-3.0.3::gentoo
>>> Installing (1 of 3) x11-libs/wxGTK-3.0.3::gentoo
>>> Emerging binary (2 of 3) dev-python/wxpython-3.0.2.0::gentoo
>>> Installing (2 of 3) dev-python/wxpython-3.0.2.0::gentoo
>>> Emerging binary (3 of 3) sci-electronics/kicad-4.0.7::gentoo
>>> Installing (3 of 3) sci-electronics/kicad-4.0.7::gentoo
>>> Jobs: 3 of 3 complete                           Load avg: 2.01, 1.40, 0.81

 * Messages for package dev-python/wxpython-3.0.2.0:

 * Gentoo uses the Multi-version method for SLOT'ing.
 * Developers, see this site for instructions on using
 * it with your apps:
 * http://wiki.wxpython.org/MultiVersionInstalls

 * Messages for package sci-electronics/kicad-4.0.7:

 * 
 * You may want to emerge media-gfx/wings if you want to create 3D models of components.
 * For help and extended documentation emerge app-doc/kicad-doc.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

И Kicad запустился нормально.

(1-1/1)

Thank you!