Diff buildah-1.30.0 with a buildah-1.32.0

/usr/portage/app-containers/buildah/buildah-1.32.0.ebuild 2023-10-09 14:52:28.216368318 +0300
3 3

  
4 4
EAPI=8
5 5

  
6
inherit bash-completion-r1 go-module
7
GIT_COMMIT=04965f11
6
inherit bash-completion-r1 go-module linux-info
7
GIT_COMMIT=2326d49
8 8

  
9 9
DESCRIPTION="A tool that facilitates building OCI images"
10 10
HOMEPAGE="https://github.com/containers/buildah"
......
12 12

  
13 13
LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
14 14
SLOT="0"
15
KEYWORDS="amd64 arm64"
16
IUSE="selinux"
15
KEYWORDS="~amd64 ~arm64"
16
IUSE="btrfs systemd doc test"
17 17
RESTRICT="test"
18 18

  
19 19
DEPEND="
20
	systemd? ( sys-apps/systemd )
21
	btrfs? ( sys-fs/btrfs-progs )
20 22
	app-crypt/gpgme:=
21
	app-containers/skopeo
22 23
	dev-libs/libgpg-error:=
23 24
	dev-libs/libassuan:=
24 25
	sys-apps/shadow:=
25
	sys-fs/lvm2:=
26 26
	sys-libs/libseccomp:=
27
	selinux? ( sys-libs/libselinux:= )
28 27
"
29 28
RDEPEND="${DEPEND}"
30 29

  
30
pkg_pretend() {
31
	local CONFIG_CHECK=""
32
	use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
33
	check_extra_config
34

  
35
	if ! linux_config_exists; then
36
		ewarn "Cannot determine configuration of your kernel."
37
	fi
38
}
39

  
31 40
src_prepare() {
32 41
	default
33
	[[ -f selinux_tag.sh ]] || die
34
	use selinux || { echo -e "#!/bin/sh\ntrue" > \
35
		selinux_tag.sh || die; }
36
	sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
42

  
43
	[[ -f hack/systemd_tag.sh ]] || die
44
	if use systemd; then
45
		echo -e '#!/usr/bin/env bash\necho systemd' > hack/systemd_tag.sh || die
46
	else
47
		echo -e '#!/usr/bin/env bash\necho' > hack/systemd_tag.sh || die
48
	fi
49

  
50
	[[ -f btrfs_installed_tag.sh ]] || die
51
	[[ -f btrfs_tag.sh ]] || die
52
	if use btrfs; then
53
		echo -e '#!/usr/bin/env bash\necho btrfs_noversion' > btrfs_tag.sh || die
54
	else
55
		echo -e '#!/usr/bin/env bash\necho exclude_graphdriver_btrfs' > btrfs_installed_tag.sh || die
56
	fi
57

  
58
	if ! use test; then
59
		cat << 'EOF' > "${T}/Makefile.patch"
60
--- Makefile
61
+++ Makefile
62
@@ -54 +54 @@
63
-all: bin/buildah bin/imgtype bin/copy bin/tutorial docs
64
+all: bin/buildah docs
65
EOF
66
		eapply -p0 "${T}/Makefile.patch"
67
	fi
37 68
}
38 69

  
39 70
src_compile() {
40 71
	emake GIT_COMMIT=${GIT_COMMIT} all
41 72
}
42 73

  
74
src_test() {
75
	emake test-unit
76
}
77

  
43 78
src_install() {
44
	dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
79
	use doc && dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
80
	use doc && dodoc -r docs/tutorials
45 81
	doman docs/*.1
46
	dodoc -r docs/tutorials
47
	dobin bin/{${PN},imgtype}
82
	dobin bin/${PN}
48 83
	dobashcomp contrib/completions/bash/buildah
49 84
}
50

  
51
src_test() {
52
	emake test-unit
53
}
Thank you!