peco-0.5.10.ebuild

Download (583 Bytes)

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go-module

DESCRIPTION="Simplistic interactive filtering tool"
HOMEPAGE="https://github.com/peco/peco"
SRC_URI="https://github.com/peco/peco/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
	https://github.com/SpiderX/portage-overlay/raw/deps/${P}-deps.tar.xz"

LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64"

DOCS=( {Changes,README.md} )

src_compile() {
	ego build ./cmd/...
}

src_test() {
	ego test ./...
}

src_install() {
	einstalldocs
	dobin peco
}

Thank you!