yojson-1.7.0.ebuild

Download (767 Bytes)

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit dune

DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
HOMEPAGE="https://github.com/ocaml-community/yojson"
SRC_URI="https://github.com/ocaml-community/yojson/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64"
IUSE="examples +ocamlopt test"
RESTRICT="!test? ( test )"

RDEPEND="
	>=dev-lang/ocaml-4.02.3:=[ocamlopt?]
	dev-ml/easy-format:=[ocamlopt?]
	>=dev-ml/biniou-1.2:=[ocamlopt?]
"
DEPEND="
	${RDEPEND}
	test? ( dev-ml/alcotest )
"
BDEPEND=">=dev-ml/cppo-1.6.1"

src_install() {
	dune_src_install

	if use examples; then
		dodoc -r examples
		docompress -x /usr/share/doc/${PF}/examples
	fi
}

Thank you!