itypes-1.2.0-r1.ebuild

Download (560 Bytes)

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )

inherit distutils-r1

DESCRIPTION="Basic immutable container types for python"
HOMEPAGE="
	https://github.com/PavanTatikonda/itypes/
	https://pypi.org/project/itypes/
"
SRC_URI="
	https://github.com/PavanTatikonda/itypes/archive/${PV}.tar.gz
		-> ${P}.gh.tar.gz
"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"

distutils_enable_tests pytest

python_test() {
	epytest tests.py
}

Thank you!