wpa_supplicant

Description:IEEE 802.1X/WPA supplicant for secure wireless transfers
License: GPL-2, BSD
Homepage:https://w1.fi/wpa_supplicant/
Location:Portage
Legend:
  • + - stable
  • ~ - unstable
  • M - hardmask
alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86
9999 diff - - - - - - - - - - - - -
2.7 diff ~ ~ ~ - ~ - ~ ~ ~ - - ~ ~
2.6-r10 diff ~ + + - ~ - ~ + + - - ~ +
2.6-r6 ~ + + - ~ - ~ + + - - ~ +

USE flags

  • ap - Add support for access point mode
  • bindist - Flag to enable or disable options for prebuilt (GRP) packages (eg. due to licensing issues)
  • dbus - Enable dbus support for anything that needs it (gpsd, gnomemeeting, etc)
  • debug - Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
  • eap-sim - Add support for EAP-SIM authentication algorithm
  • eapol_test - Build and install eapol_test binary
  • fasteap - Add support for FAST-EAP authentication algorithm
  • gnutls - Prefer net-libs/gnutls as SSL/TLS provider (ineffective with USE=-ssl)
  • hs2-0 - Add support for 802.11u and Passpoint for HotSpot 2.0
  • kernel_FreeBSD - KERNEL setting for system using the FreeBSD kernel
  • kernel_linux - KERNEL setting for system using the Linux kernel
  • libressl - Use dev-libs/libressl instead of dev-libs/openssl when applicable (see also the ssl useflag)
  • p2p - Add support for Wi-Fi Direct mode
  • privsep - Enable wpa_priv privledge separation binary
  • ps3 - Add support for ps3 hypervisor driven gelic wifi
  • qt4 - Add support for the Qt GUI/Application Toolkit version 4.x
  • qt5 - Add support for the Qt 5 application and UI framework
  • readline - Enable support for libreadline, a GNU line-editing library that almost everyone wants
  • selinux - !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur
  • smartcard - Add support for smartcards
  • ssl - Add support for SSL/TLS connections (Secure Socket Layer / Transport Layer Security)
  • suiteb - Enable enable NSA Suite B encryption
  • tdls - Add support for Tunneled Direct Link Setup (802.11z)
  • uncommon-eap-types - Add support for GPSK, SAKE, GPSK_SHA256, IKEV2 and EKE
  • wimax - Add support for Wimax EAP-PEER authentication algorithm
  • wps - Add support for Wi-Fi Protected Setup

Security Advisory

Date Severity Title
about 1 year normal hostapd and wpa_supplicant: Key Reinstallation (KRACK) attacks
over 2 years normal hostapd and wpa_supplicant: Multiple vulnerabilities
almost 14 years normal wpa_supplicant: Buffer overflow vulnerability

Also available in: Atom

Thank you!